`
java-mans
  • 浏览: 11426854 次
文章分类
社区版块
存档分类
最新评论

hdu 3033 I love sneakers! 分组背包之每组至少取一个

 
阅读更多

I love sneakers!

Time Limit: 2000/1000 MS (Java/Others)Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1895Accepted Submission(s): 764


Problem Description
After months of hard working, Iserlohn finally wins awesome amount of scholarship. As a great zealot of sneakers, he decides to spend all his money on them in a sneaker store.

There are several brands of sneakers that Iserlohn wants to collect, such as Air Jordan and Nike Pro. And each brand has released various products. For the reason that Iserlohn is definitely a sneaker-mania, he desires to buy at least one product for each brand.
Although the fixed price of each product has been labeled, Iserlohn sets values for each of them based on his own tendency. With handsome but limited money, he wants to maximize the total value of the shoes he is going to buy. Obviously, as a collector, he won’t buy the same product twice.
Now, Iserlohn needs you to help him find the best solution of his problem, which means to maximize the total value of the products he can buy.

Input
Input contains multiple test cases. Each test case begins with three integers 1<=N<=100 representing the total number of products, 1 <= M<= 10000 the money Iserlohn gets, and 1<=K<=10 representing the sneaker brands. The following N lines each represents a product with three positive integers 1<=a<=k, b and c, 0<=b,c<100000, meaning the brand’s number it belongs, the labeled price, and the value of this product. Process to End Of File.

Output
For each test case, print an integer which is the maximum total value of the sneakers that Iserlohn purchases. Print "Impossible" if Iserlohn's demands can’t be satisfied.

Sample Input
5 10000 3 1 4 6 2 5 7 3 4 99 1 55 77 2 44 66

Sample Output
255

Source

题意:

Iserlohn 要买运动鞋,商店总共有n双运动鞋Iserlohn喜欢,他总共有V元钱,这些运动鞋分为k类,没类都有自己的编号id,单价p,对Iserlohn的价值v。Iserlohn想每一类运动鞋至少买一双,在不超过他所拥有的总金额前提下,使他得到的v最大。

直接套模板 模板在我的日志

hdu 3535 涵盖了分组背包的各种情况 非常好的背包题目

#include<stdio.h>
#include<string.h>
struct haha
{
int val;
int cost;
}a[15][105];
int val,cost,num[15],dp[12][10010];//数组dp[i][j],表示第i组,时间剩余为j时的价值
int mmax(int x,int y)
{
if(x>y) return x;
else return y;
}
int main()
{
int n,m,ki,k,i,j,flag,ans;
while(scanf("%d %d %d",&n,&m,&ki)!=EOF)
{
memset(num,0,sizeof(num));
memset(dp,0,sizeof(dp));
for(i=1;i<=n;i++)
{
scanf("%d %d %d",&flag,&cost,&val);
a[flag][num[flag]].cost=cost;
a[flag][num[flag]++].val=val;
}
for(i=1;i<=ki;i++)
{
for(j=0;j<=m;j++)
dp[i][j]=-1000000;

for(j=0;j<num[i];j++)
for(k=m;k>=a[i][j].cost;k--)
{
dp[i][k]=mmax(dp[i][k],dp[i][k-a[i][j].cost]+a[i][j].val);
dp[i][k]=mmax(dp[i][k],dp[i-1][k-a[i][j].cost]+a[i][j].val);

}
}
ans=dp[ki][m];
if(ans<=0) printf("Impossible\n");
else
printf("%d\n",ans);

}
return 0;
}

分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics