`
java-mans
  • 浏览: 11389655 次
文章分类
社区版块
存档分类
最新评论

hdu1114 Piggy-Bank 求最小值的背包

 
阅读更多

Piggy-Bank

Time Limit: 2000/1000 MS (Java/Others)Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4603Accepted Submission(s): 2269


Problem Description
Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid.

But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs!

Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it's weight in grams.

Output
Print exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line "This is impossible.".

Sample Input
310 11021 130 5010 11021 150 301 6210 320 4

Sample Output
The minimum amount of money in the piggy-bank is 60.The minimum amount of money in the piggy-bank is 100.This is impossible.

题意:一个储钱罐,知道里面硬币的重量,现在提供N种类型的硬币的重量和价格(数目无限),求储钱罐里面最少的价值。

即:求出把背包装满可以获得的最小的价值.
唯一的区别就是初始化
该题利用了我们的逆向思维,同时要注意该题他的质量是一定的,也就是说背包一定要是满的,刚开始对于这类背包我们令初始值是负无穷,而这题则相反,令初始值是正无穷,每次区最小的数,

同时要注意f[j-weight[i]]!=inf应为一相等就与背包一定要满的条件相矛盾; 但是这个条件我没有去用 会稍微浪费点时间把

因为要正好填满 所以必须要初始化很大

#include<stdio.h>
int val[600],wei[600],bag[10005];
int _bag(int v,int n)
{
int i,j;
for(i=0;i<n;i++)
{
for(j=wei[i];j<=v;j++)
{
bag[j]=(bag[j-wei[i]]+val[i])<bag[j]?(bag[j-wei[i]]+val[i]):bag[j];
// printf("%d ",bag[j]);
}
// printf("\n");
}
return bag[v];
}
int main()
{
int t,i,n,v,e,f,ans;
scanf("%d",&t);
while(t--)
{
scanf("%d %d",&e,&f);
v=f-e;
for(i=0;i<v+3;i++)
bag[i]=999999999;
bag[0]=0;
scanf("%d",&n);
for(i=0;i<n;i++)
scanf("%d %d",&val[i],&wei[i]);
ans=_bag(v,n);
if(ans==999999999) printf("This is impossible.\n");
else printf("The minimum amount of money in the piggy-bank is %d.\n",ans);
}
return 0;
}

分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics