`
java-mans
  • 浏览: 11392534 次
文章分类
社区版块
存档分类
最新评论

hdu1160 FatMouse's Speed 最长上升子序列以及记录路径 DP

 
阅读更多


FatMouse's Speed

Time Limit: 2000/1000 MS (Java/Others)Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5102Accepted Submission(s): 2222
Special Judge


Problem Description
FatMouse believes that the fatter a mouse is, the faster it runs. To disprove this, you want to take the data on a collection of mice and put as large a subset of this data as possible into a sequence so that the weights are increasing, but the speeds are decreasing.

Input
Input contains data for a bunch of mice, one mouse per line, terminated by end of file.

The data for a particular mouse will consist of a pair of integers: the first representing its size in grams and the second representing its speed in centimeters per second. Both integers are between 1 and 10000. The data in each test case will contain information for at most 1000 mice.

Two mice may have the same weight, the same speed, or even the same weight and speed.

Output
Your program should output a sequence of lines of data; the first line should contain a number n; the remaining n lines should each contain a single positive integer (each one representing a mouse). If these n integers are m[1], m[2],..., m[n] then it must be the case that

W[m[1]] < W[m[2]] < ... < W[m[n]]

and

S[m[1]] > S[m[2]] > ... > S[m[n]]

In order for the answer to be correct, n should be as large as possible.
All inequalities are strict: weights must be strictly increasing, and speeds must be strictly decreasing. There may be many correct outputs for a given input, your program only needs to find one.

Sample Input
6008 1300
6000 2100
500 2000
1000 4000
1100 3000
6000 2000
8000 1400
6000 1200
2000 1900

Sample Output
4
4
5
9
7
这题的数据貌似不是很强大 我一开始不会做 参考了别人的代码才拍了 出来 甚至样例都和题目不一样 也过了 其实通过这个题目有了一点经验 题目中说可能有很多条 只要选你能够发现的那条就行了 这样发挥的空间比较大
所以遇到这种提示的时候 做题目 有时候和样例不一样 又感觉自己的方法应该没问题 要果断提交 不一定非要和样例一样
去除排序的第二级排序 也能A

题目大意是找到一个最多的老鼠序列,使得序列中的老鼠的体重满足递增,相应老鼠的速度满足递减。思路就是先按体重递增进行sort排序,然后按照体重找到最长递减子序列即可,用动态规划做比较简单。状态f[i]表示前i个老鼠中的最长递减子序列长度,状态转移方程为f[i] = max{f[j], mice[j].speed > mice[i].speed} + 1, 最后找出最大的f[i]即可。注意此题还需要输出找到的序列中的老鼠的最原始的标号,因此不仅要在刚开始的时候把每个老鼠的最初的序号记下来,还要在进行状态转移的时候把当前的老鼠的位置标记下来。

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
struct haha
{
 int wei;
 int spe;
 int num;
}a[1010];
int cmp(const void *a,const void *b)
{
 if((*(struct haha *)a).wei!=(*(struct haha *)b).wei)
 return (*(struct haha *)a).wei-(*(struct haha *)b).wei;
 else return (*(struct haha *)b).spe-(*(struct haha *)a).spe;
}
int l[1010],pre[1010],ans[1010];//l是记录的长度 pre记录的是路径
int main()
{
 int cnt=1,i,j,max_l=0,end;
      while(scanf("%d %d",&a[cnt].wei,&a[cnt].spe)!=EOF)
   {
    a[cnt].num=cnt++;
   }
   qsort(a+1,cnt-1,sizeof(struct haha),cmp);
   for(i=1;i<cnt;i++) {l[i]=1;pre[i]=0;}
      for(i=1;i<cnt;i++)
   {
    for(j=1;j<i;j++)
    {
         if(a[i].wei>a[j].wei&&a[i].spe<a[j].spe&&l[i]<l[j]+1)
      {
       l[i]=l[j]+1;
       pre[i]=j;//这里面记录的是倒序 后面要倒着输出
      }
    }
   }
   end=1;
   max_l=l[1];
   for(i=2;i<cnt;i++) if(max_l<l[i]) {max_l=l[i];end=i;}
   printf("%d\n",max_l);
   for(i=1;i<cnt;i++)//记录下来  方便倒着输出
   {
            ans[i]=end;    
   end=pre[end];
   }
   for(i=max_l;i>=1;i--)
   {
             printf("%d\n",a[ans[i]].num);
   }
     return 0;
   
}

分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics