`
java-mans
  • 浏览: 11450301 次
文章分类
社区版块
存档分类
最新评论

hdu4310 Hero 贪心

 
阅读更多

Hero


Problem Description
When playing DotA with god-like rivals and pig-like team members, you have to face an embarrassing situation: All your teammates are killed, and you have to fight 1vN.

There are two key attributes for the heroes in the game, health point (HP) and damage per shot (DPS). Your hero has almost infinite HP, but only 1 DPS.

To simplify the problem, we assume the game is turn-based, but not real-time. In each round, you can choose one enemy hero to attack, and his HP will decrease by 1. While at the same time, all the lived enemy heroes will attack you, and your HP will decrease by the sum of their DPS. If one hero's HP fall equal to (or below) zero, he will die after this round, and cannot attack you in the following rounds.

Although your hero is undefeated, you want to choose best strategy to kill all the enemy heroes with minimum HP loss.

Input
The first line of each test case contains the number of enemy heroes N (1 <= N <= 20). Then N lines followed, each contains two integers DPSi and HPi, which are the DPS and HP for each hero. (1 <= DPSi, HPi <= 1000)

Output
Output one line for each test, indicates the minimum HP loss.

Sample Input
110 22100 11 100

Sample Output
20201

Source
2012 Multi-University Training Contest 2

题意:有n组敌人,每次攻击一个敌人会使这个敌人的HP减1,但是同时我的DPS(开始是是无穷的)的值会减少所有没消灭的敌人的DPS总和,要求将所有的敌人都消灭后我的DPS剩余的最多,即求耗费的DPS的值最少。



#include<stdio.h>
#include<stdlib.h>
struct haha
{
int gj;
int flood;
double val;
}per[100];
int cmp(const void *a,const void *b)
{
if((*(struct haha *)a).val!=(*(struct haha *)b).val)
return (*(struct haha *)a).val>(*(struct haha *)b).val?-1:1;
else return (*(struct haha *)b).gj-(*(struct haha *)a).gj;
}
int main()
{
int n,i;
__int64 sum,ans;
while(scanf("%d",&n)!=EOF)
{
sum=ans=0;
for(i=0;i<n;i++)
{
scanf("%d %d",&per[i].gj,&per[i].flood);
per[i].val=(double)per[i].gj/per[i].flood;
sum+=per[i].gj;
}
qsort(per,n,sizeof(per[0]),cmp);
for(i=0;i<n;i++)
{
ans+=per[i].flood*sum;
sum-=per[i].gj;
}
printf("%I64d\n",ans);

}
return 0;
}

分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics