`
java-mans
  • 浏览: 11340631 次
文章分类
社区版块
存档分类
最新评论

hdu1548 A strange lift 不错的变相最短路考察

 
阅读更多

A strange lift

Time Limit: 2000/1000 MS (Java/Others)Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5507Accepted Submission(s): 2009


Problem Description
There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 <= Ki <= N) on every floor.The lift have just two buttons: up and down.When you at floor i,if you press the button "UP" , you will go up Ki floor,i.e,you will go to the i+Ki th floor,as the same, if you press the button "DOWN" , you will go down Ki floor,i.e,you will go to the i-Ki th floor. Of course, the lift can't go up high than N,and can't go down lower than 1. For example, there is a buliding with 5 floors, and k1 = 3, k2 = 3,k3 = 1,k4 = 2, k5 = 5.Begining from the 1 st floor,you can press the button "UP", and you'll go up to the 4 th floor,and if you press the button "DOWN", the lift can't do it, because it can't go down to the -2 th floor,as you know ,the -2 th floor isn't exist.
Here comes the problem: when you is on floor A,and you want to go to floor B,how many times at least he havt to press the button "UP" or "DOWN"?

Input
The input consists of several test cases.,Each test case contains two lines.
The first line contains three integers N ,A,B( 1 <= N,A,B <= 200) which describe above,The second line consist N integers k1,k2,....kn.
A single 0 indicate the end of the input.

Output
For each case of the input output a interger, the least times you have to press the button when you on floor A,and you want to go to floor B.If you can't reach floor B,printf "-1".

Sample Input
5 1 5
3 3 1 2 5
0

Sample Output
3
/*题意是在某一层的楼梯 电梯只能上或者下相应的层数 从a-》b最少要上下多少次
如果不能从a到b则输入-1 变形的最短路问题 层数就是点 看第几层和第几层有路
此题比较简单 */
#include<stdio.h>
#include<string.h>
int map[205][205],used[205],min[205],n,start,end;
void init()
{
	int i,j;
	for(i=1;i<=n;i++)
		for(j=1;j<=n;j++)
            if(i!=j) map[i][j]=999999999;
			else map[0][0]=0;
}
void find_short()
{
	int i,j,mm,pos;
	memset(used,0,sizeof(used));
	for(i=1;i<=n;i++)
		min[i]=map[start][i];
	min[start]=0; used[start]=1;
	for(i=2;i<=n;i++)
	{
		pos=0;
		mm=999999999;
		for(j=1;j<=n;j++)
		{
			if(!used[j]&&mm>min[j])
			{
				pos=j;
				mm=min[j];
			}
		}
		used[pos]=1;
		if(mm==999999999)  break;
		for(j=1;j<=n;j++)
		{
			if(!used[j]&&min[pos]+map[pos][j]<min[j])
				min[j]=min[pos]+map[pos][j];
		}
	}
}
int main()
{
	int i,d;
	while(scanf("%d",&n)!=EOF)
	{
		if(n==0) break;
		scanf("%d %d",&start,&end);
		init();
		for(i=1;i<=n;i++)
		{
			scanf("%d",&d);
			if(i-d>=1) map[i][i-d]=1;
			if(i+d<=n) map[i][i+d]=1;
		}
		find_short();
		if(min[end]==999999999) printf("-1\n");
		else
			printf("%d\n",min[end]);
	}
	return 0;
}




分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics