`
java-mans
  • 浏览: 11341050 次
文章分类
社区版块
存档分类
最新评论

hdu3342 Legal or Not 拓扑排序

 
阅读更多

Legal or Not

Time Limit: 2000/1000 MS (Java/Others)Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1883Accepted Submission(s): 817


Problem Description
ACM-DIY is a large QQ group where many excellent acmers get together. It is so harmonious that just like a big family. Every day,many "holy cows" like HH, hh, AC, ZT, lcc, BF, Qinz and so on chat on-line to exchange their ideas. When someone has questions, many warm-hearted cows like Lost will come to help. Then the one being helped will call Lost "master", and Lost will have a nice "prentice". By and by, there are many pairs of "master and prentice". But then problem occurs: there are too many masters and too many prentices, how can we know whether it is legal or not?

We all know a master can have many prentices and a prentice may have a lot of masters too, it's legal. Nevertheless,some cows are not so honest, they hold illegal relationship. Take HH and 3xian for instant, HH is 3xian's master and, at the same time, 3xian is HH's master,which is quite illegal! To avoid this,please help us to judge whether their relationship is legal or not.

Please note that the "master and prentice" relation is transitive. It means that if A is B's master ans B is C's master, then A is C's master.

Input
The input consists of several test cases. For each case, the first line contains two integers, N (members to be tested) and M (relationships to be tested)(2 <= N, M <= 100). Then M lines follow, each contains a pair of (x, y) which means x is y's master and y is x's prentice. The input is terminated by N = 0.
TO MAKE IT SIMPLE, we give every one a number (0, 1, 2,..., N-1). We use their numbers instead of their names.

Output
For each test case, print in one line the judgement of the messy relationship.
If it is legal, output "YES", otherwise "NO".

Sample Input
3 2
0 1
1 2
2 2
0 1
1 0
0 0

Sample Output
YESNO
题意:a是b的老师 b是c的老师 那么a是c的老师 如果a是b的老师 b是c的老师 c是a的老师 这样是不合法的
#include<stdio.h>
#include<string.h>
int map[105][105],in[105];
int m,n;
void print()
{
 int i,j,num=0,cnt=0;
 for(num=0;num<n;num++)
 {
  for(i=0;i<n;i++)
  {
   if(in[i]==0)
   {
    in[i]--;
    cnt++;
    for(j=0;j<n;j++)
     if(map[i][j]) in[j]--;
     break;
   }
  }
  if(i==n) {printf("NO\n");return;}
 }
 if(cnt==n) printf("YES\n");
 else printf("NO\n");
}
int main()
{
 int i,x,y;
 while(scanf("%d %d",&n,&m)!=EOF)
 {
  if(n==0) break;
  memset(map,0,sizeof(map));
  memset(in,0,sizeof(in));
  for(i=0;i<m;i++)
  {
   scanf("%d %d",&x,&y);
   if(!map[x][y])//主要是这个地方  千千万万不要忘记 每次都是错在这里  这里加上要防止重边的出现
   {
     map[x][y]=1;
     in[y]++;
   }
  }
  print();
 }
 return 0;
}


分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics