`
java-mans
  • 浏览: 11341464 次
文章分类
社区版块
存档分类
最新评论

hdu1258 确定比赛名次 邻接表法拓扑排序

 
阅读更多

确定比赛名次

Time Limit: 2000/1000 MS (Java/Others)Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5135Accepted Submission(s): 1910


Problem Description
有 N个比赛队(1<=N<=500),编号依次为1,2,3,。。。。,N进行比赛,比赛结束后,裁判委员会要将所有参赛队伍从前往后依次排名,但现在裁判委员会不能直接获得每个队的比赛成绩,只知道每场比赛的结果,即P1赢P2,用P1,P2表示,排名时P1在P2之前。现在请你编程序确定排名。

Input
输入有若干组,每组中的第一行为二个数N(1<=N<=500),M;其中N表示队伍的个数,M表示接着有M行的输入数据。接下来的M行数据中,每行也有两个整数P1,P2表示即P1队赢了P2队。

Output
给出一个符合要求的排名。输出时队伍号之间有空格,最后一名后面没有空格。

其他说明:符合条件的排名可能不是唯一的,此时要求输出时编号小的队伍在前;输入数据保证是正确的,即输入数据确保一定能有一个符合要求的排名。

Sample Input
4 3
1 2
2 3
4 3

Sample Output
1 2 4 3
#include<stdio.h>
#include<malloc.h>
#include<queue>
using namespace std;
int m,n;
struct haha
{
	int son;
	struct haha *nextson;
}*e[505];
int in[505],ans[505];
void add_edge(int x,int y)
{
	struct haha *p;
	p=(struct haha *)malloc(sizeof(struct haha));
	p->son=y;
	p->nextson=e[x];
	e[x]=p;
}
int main()
{
	int i,x,y,num,cnt;
	while(scanf("%d %d",&n,&m)!=EOF)
	{
		num=n;cnt=0;
		for(i=1;i<=n;i++)
		{
			e[i]=NULL;
			in[i]=0;
		}
		for(i=1;i<=m;i++)
		{
			scanf("%d %d",&x,&y);
			add_edge(x,y);
			in[y]++;
		}
		priority_queue<int,vector<int>,greater<int> >duilie;//注意这里要把》 》 分开 写
		for(i=1;i<=n;i++)
			if(in[i]==0) duilie.push(i);
			while(!duilie.empty())
			{
				x=duilie.top();
				duilie.pop();
				ans[cnt++]=x;
				struct haha *p;
				p=e[x];
				while(p!=NULL)
				{
					if(--in[p->son]==0) duilie.push(p->son);
					p=p->nextson;
				}
			}
			for(i=0;i<cnt-1;i++)
				printf("%d ",ans[i]);
			printf("%d\n",ans[cnt-1]);
	}
	return 0;
}


分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics