`
java-mans
  • 浏览: 11386802 次
文章分类
社区版块
存档分类
最新评论

hdu 3535 涵盖了分组背包的各种情况 非常好的背包题目

 
阅读更多

AreYouBusy

Time Limit: 2000/1000 MS (Java/Others)Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1394Accepted Submission(s): 529


Problem Description
Happy New Term!
As having become a junior, xiaoA recognizes that there is not much time for her to AC problems, because there are some other things for her to do, which makes her nearly mad.
What's more, her boss tells her that for some sets of duties, she must choose at least one job to do, but for some sets of things, she can only choose at most one to do, which is meaningless to the boss. And for others, she can do of her will. We just define the things that she can choose as "jobs". A job takes time , and gives xiaoA some points of happiness (which means that she is always willing to do the jobs).So can you choose the best sets of them to give her the maximum points of happiness and also to be a good junior(which means that she should follow the boss's advice)?


Input
There are several test cases, each test case begins with two integers n and T (0<=n,T<=100) , n sets of jobs for you to choose and T minutes for her to do them. Follows are n sets of description, each of which starts with two integers m and s (0<m<=100), there are m jobs in this set , and the set type is s, (0 stands for the sets that should choose at least 1 job to do, 1 for the sets that should choose at most 1 , and 2 for the one you can choose freely).then m pairs of integers ci,gi follows (0<=ci,gi<=100), means the ith job cost ci minutes to finish and gi points of happiness can be gained by finishing it. One job can be done only once.


Output
One line for each test case contains the maximum points of happiness we can choose from all jobs .if she can’t finish what her boss want, just output -1 .


Sample Input
3 3 2 1 2 5 3 8 2 0 1 0 2 1 3 2 4 3 2 1 1 1 3 4 2 1 2 5 3 8 2 0 1 1 2 8 3 2 4 4 2 1 1 1 1 1 1 0 2 1 5 3 2 0 1 0 2 1 2 0 2 2 1 1 2 0 3 2 2 1 2 1 1 5 2 8 3 2 3 8 4 9 5 10


Sample Output
5 13 -1 -1


Author
hphp


Source


/*
题意 xiaoA想尽量多花时间做ACM,但老板要求他在t时间内做完n堆工作,每个工作耗时cost,
得到幸福感val,每个工作有num[i]个工作,每堆工作都有一个性质,0表示至少要做里面的1个工作,
1表示最多做里面的1个工作,2表示随意,做或不做都行。最后问在符合老板要求的情况下的最大幸福感,
怎么都不符合要求就输出-1.

题意是有n组背包,每组有一个属性:0表示该组内必须取一个,1表示该组内最多取一个,
2表示该组内可以任意取。每组背包内有一些物品,有一定的价值和花费值。最后给定花费求最大价值。

思路:

数组dp[i][j],表示第i组,时间剩余为j时的快乐值。每得到一组工作就进行一次DP,所以dp[i]为第i组的结果


第一类

至少选一项,即必须要选,那么在开始时,对于这一组的dp的初值,应该全部赋为负无穷,
这样才能保证不会出现都不选的情况。状态转移方程为dp[i][k]=max{ dp[i][k],dp[i-1][k-cost[j]]+val[k],dp[i][k-cost[j]]+val[j] }。
dp[i][k]是不选择当前工作;dp[i-1][k-cost[j]]+val[k]是选择当前工作,但是是第一次在本组中选,
由于开始将该组dp赋为了负无穷,所以第一次取时,必须由上一组的结果推知,这样才能保证得到全局最优解;
dp[i][k-cost[j]]+val[j]表示选择当前工作,并且不是第一次取。

第二类

最多选一项,即要么不选,一旦选,只能是第一次选。
所以状态转移方程为dp[i][k]=max{ dp[i][k],dp[i-1][k-cost[j]]+val[k]}。
由于要保证得到全局最优解,所以在该组DP开始以前,应该将上一组的DP结果先复制到这一组的dp[i]数组里,
因为这一组的数据是在上一组数据的基础上进行更新的。

第三类

任意选,即不论选不选,选几次都可以,
显然状态转移方程为dp[i][k]=max{ dp[i][k],dp[i-1][k-cost[j]]+val[k],dp[i][k-cost[j]]+val[j] }
。同样要保证为得到全局最优解,先复制上一组解。

以上为参考作者 ‘ 等待电子的砹 ’ 的文章

*/
#include<stdio.h>
#include<string.h>
#include<limits.h>
int n,t;
int dp[110][110],cost[110],val[110];
int mmax(int x,int y)
{
if(x>y) return x;
else return y;
}
int main()
{
int i,j,flag,m,k,ans;
while(scanf("%d %d",&n,&t)!=EOF)
{
memset(dp,0,sizeof(dp));
for(i=1;i<=n;i++)
{
scanf("%d %d",&m,&flag);//m是每组的个数
for(j=1;j<=m;j++)
{
scanf("%d %d",&cost[j],&val[j]);
}
if(flag==0)//当前组至少拿一个
{
for(j=0;j<=t;j++)
dp[i][j]=-1000000;//INT_MIN;//为了保证至少拿一个
for(j=1;j<=m;j++)
for(k=t;k>=cost[j];k--)
{
dp[i][k]=mmax(dp[i][k],dp[i][k-cost[j]]+val[j]);//这句话与下面那句话不能交换位置 不知道为什么
dp[i][k]=mmax(dp[i][k],dp[i-1][k-cost[j]]+val[j]);


}

}
else if(flag==1)//当前组最多拿一个
{
for(j=0;j<=t;j++)
dp[i][j]=dp[i-1][j];
for(j=1;j<=m;j++)
for(k=t;k>=cost[j];k--)
{
dp[i][k]=mmax(dp[i][k],dp[i-1][k-cost[j]]+val[j]);
}
}
else //当前组随便拿多少个
{
for(j=0;j<=t;j++)
dp[i][j]=dp[i-1][j];
for(j=1;j<=m;j++)
for(k=t;k>=cost[j];k--)
{
dp[i][k]=mmax(dp[i][k],dp[i][k-cost[j]]+val[j]);
dp[i][k]=mmax(dp[i][k],dp[i-1][k-cost[j]]+val[j]);
}
}
}
ans=mmax(dp[n][t],-1);
printf("%d\n",ans);
//printf("%d\n",dp[n][t]);
}
return 0;
}

分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics