`
java-mans
  • 浏览: 11414518 次
文章分类
社区版块
存档分类
最新评论

hdu1398 Square Coins 母函数水题

 
阅读更多

Square Coins

Time Limit: 2000/1000 MS (Java/Others)Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5101Accepted Submission(s): 3447


Problem Description
People in Silverland use square coins. Not only they have square shapes but also their values are square numbers. Coins with values of all square numbers up to 289 (=17^2), i.e., 1-credit coins, 4-credit coins, 9-credit coins, ..., and 289-credit coins, are available in Silverland.
There are four combinations of coins to pay ten credits:

ten 1-credit coins,
one 4-credit coin and six 1-credit coins,
two 4-credit coins and two 1-credit coins, and
one 9-credit coin and one 1-credit coin.

Your mission is to count the number of ways to pay a given amount using coins of Silverland.

Input
The input consists of lines each containing an integer meaning an amount to be paid, followed by a line containing a zero. You may assume that all the amounts are positive and less than 300.

Output
For each of the given amount, one line containing a single integer representing the number of combinations of coins should be output. No other characters should appear in the output.

Sample Input
2 10 30 0

Sample Output
1 4
27
题意 :
有17中硬币 分别是1到17的 数字的平方
问输入n 有几种表示方案
27
#include<stdio.h>
#include<string.h>
int a[20];
void get()
{
	int i;
	for(i=1;i<=17;i++)
		a[i]=i*i;
	
}
int main()
{
	int i,j,n,k;
	int c1[500],c2[500];
	get();
	while(scanf("%d",&n)!=EOF)
	{
		if(!n) break;
		memset(c1,0,sizeof(c1));
		memset(c2,0,sizeof(c2));
		for(i=0;i<=n;i++)
			c1[i]=1;//printf("ca");
	//	printf("?");
        for(i=2;i<=17;i++)
		{
			for(j=0;j<=n;j++)
				for(k=0;k+j<=n;k+=a[i])
					c2[k+j]+=c1[j];
			for(j=0;j<=n;j++)
			{
				c1[j]=c2[j];
				c2[j]=0;
			}
		}
		printf("%d\n",c1[n]);
	}
	return 0;
}

分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics