`
java-mans
  • 浏览: 11380694 次
文章分类
社区版块
存档分类
最新评论

hdu 1787 GCD Again 欧拉函数小水水 数论

 
阅读更多

GCD Again

Time Limit: 1000/1000 MS (Java/Others)Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1542Accepted Submission(s): 578


Problem Description
Do you have spent some time to think and try to solve those unsolved problem after one ACM contest?
No? Oh, you must do this when you want to become a "Big Cattle".
Now you will find that this problem is so familiar:
The greatest common divisor GCD (a, b) of two positive integers a and b, sometimes written (a, b), is the largest divisor common to a and b. For example, (1, 2) =1, (12, 18) =6. (a, b) can be easily found by the Euclidean algorithm. Now I am considering a little more difficult problem:
Given an integer N, please count the number of the integers M (0<M<N) which satisfies (N,M)>1.
This is a simple version of problem “GCD” which you have done in a contest recently,so I name this problem “GCD Again”.If you cannot solve it still,please take a good think about your method of study.
Good Luck!

Input
Input contains multiple test cases. Each test case contains an integers N (1<N<100000000). A test case containing 0 terminates the input and this test case is not to be processed.

Output
For each integers N you should output the number of integers M in one line, and with one line of output for each line in input.

Sample Input
2 4 0

Sample Output
0 1

Author
lcy

Source

Recommend
lcy
题意:
求小于n的gcd(i,n)大于1的个数
思路 : 欧拉函数直接求gcd(i,n)==1的个数 用n减即可
#include<stdio.h>
#include<math.h>
__int64 euler(__int64 x)// 就是公式   
{  
    __int64 i, res=x;  
    for (i = 2; i <(__int64)sqrt(x * 1.0) + 1; i++)  
        if(x%i==0)  
        {  
            res = res /(__int64)i*(i - 1);
			
            while (x % i == 0) x /= i; // 保证i一定是素数    
        }  
        if (x > 1) res = res / (__int64)x*(x - 1);//这里小心别溢出了   
        return res;  
}  

int main()
{
	__int64 n;
    while(scanf("%I64d",&n)!=EOF)
	{
		if(!n) break;
		printf("%I64d\n",n-euler(n)-1);
	}
	 return 0;
}

分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics