`
java-mans
  • 浏览: 11414624 次
文章分类
社区版块
存档分类
最新评论

HDU 1372 knight moves

 
阅读更多
Problem Description
A friend of you is doing research on the Traveling Knight Problem (TKP) where you are to find the shortest closed tour of knight moves that visits each square of a given set of n squares on a chessboard exactly once. He thinks that the most difficult part of the problem is determining the smallest number of knight moves between two given squares and that, once you have accomplished this, finding the tour would be easy.
Of course you know that it is vice versa. So you offer him to write a program that solves the "difficult" part.

Your job is to write a program that takes two squares a and b as input and then determines the number of knight moves on a shortest route from a to b.

Input
The input file will contain one or more test cases. Each test case consists of one line containing two squares separated by one space. A square is a string consisting of a letter (a-h) representing the column and a digit (1-8) representing the row on the chessboard.

Output
For each test case, print one line saying "To get from xx to yy takes n knight moves.".

Sample Input
e2 e4 a1 b2 b2 c3 a1 h8 a1 h7 h8 a1 b1 c3 f6 f6

Sample Output
To get from e2 to e4 takes 2 knight moves. To get from a1 to b2 takes 4 knight moves. To get from b2 to c3 takes 2 knight moves. To get from a1 to h8 takes 6 knight moves. To get from a1 to h7 takes 5 knight moves. To get from h8 to a1 takes 6 knight moves. To get from b1 to c3 takes 1 knight moves. To get from f6 to f6 takes 0 knight moves.
#include<iostream>
#include<cstring>
#include<queue>
using namespace std;
const int dir[8][2]={{-1,-2},{-2,-1},{-2,1},{-1,2},{1,2},{2,1},{2,-1},{1,-2}};
struct node{int x,y,step;};
queue<node>que;
bool matrix[9][9];
int ax,ay,bx,by;
node cur,pre;
int bfs()
{
    int i;
    if(ax==bx&&ay==by)return 0;
    cur.x=ax,cur.y=ay,cur.step=0;
    memset(matrix,0,sizeof(matrix));
    while(!que.empty())que.pop();
    matrix[ax][ay]=1;
    que.push(cur);
    while(!que.empty())
    {
        cur=que.front(),que.pop();
        cur.step++;
        for(i=0;i<8;i++)
        {
            ax=cur.x+dir[i][0];
            ay=cur.y+dir[i][1];
            if(ax>0&&ax<9&&ay>0&&ay<9&&!matrix[ax][ay])
            {
                matrix[ax][ay]=1;
                if(ax==bx&&ay==by)return cur.step;
                pre.x=ax,pre.y=ay,pre.step=cur.step;
                que.push(pre);
            }
        }
    }
    return -1;
}
int main()
{
    char t1,t2;
    int temp;
    while(cin>>t1>>ay>>t2>>by)
    {
        temp=ay;
        ax=t1-'a'+1;bx=t2-'a'+1;
        cout<<"To get from "<<t1<<temp<<" to "<<t2<<by<<" takes "<<bfs()<<" knight moves."<<endl;
    }
    return 0;
}


分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics