`
java-mans
  • 浏览: 11435744 次
文章分类
社区版块
存档分类
最新评论

HDU 1711 Number Sequence

 
阅读更多
Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.

Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].

Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.

Sample Input
2 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 1 3 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 2 1

Sample Output
6 -1
字符串匹配的一个变形。
#include<stdio.h>
#include<string.h>
int next[10005];
int s[1000005],p[10005];
int n,m;
void getNext(int p[])
{
    int i=0,j=-1,len=m-1;
    next[0]=-1;
    while(i<len)
    {
        if(j==-1||p[i]==p[j])
        {
            i++,j++;
            next[i]=j;}
        else j=next[j];
    }
}
int kmp(int n,int m)
{
    int i=0,j=0;
    while(i<n&&j<m)
    {
        if(j==-1||s[i]==p[j])
        i++,j++;
        else j=next[j];
    }
    if(j==m)return i-j+1;
    else return -1;
}
int main()
{
    int t,i,j;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        for(i=0;i<n;i++)
        scanf("%d",&s[i]);
        for(j=0;j<m;j++)
        scanf("%d",&p[j]);
        getNext(p);
        printf("%d\n",kmp(n,m));
    }
    return 0;
}


分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics