`
java-mans
  • 浏览: 11454206 次
文章分类
社区版块
存档分类
最新评论

HDU 2602 Bone Collector

 
阅读更多
Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?


Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

Output
One integer per line representing the maximum of the total value (this number will be less than 231).

Sample Input
1 5 10 1 2 3 4 5 5 4 3 2 1

Sample Output
14
经典01背包问题
f[j]=max(f[j],f[j-cost[i]]+get[i])
LANGUAGE:C
CODE:
#include<stdio.h>
#define max(a,b) a>b?a:b
int cost[1002],get[1002],f[1002];
int main()
{
    int testCase,N,V,i,j;
    scanf("%d",&testCase);
    while(testCase--)
    {
        scanf("%d%d",&N,&V);
        for(i=0;i<=V;i++)f[i]=0;
        for(i=1;i<=N;i++)
        scanf("%d",&get[i]);
        for(i=1;i<=N;i++)
        scanf("%d",&cost[i]);
        for(i=1;i<=N;i++)
            for(j=V;j>=cost[i];j--)
            f[j]=max(f[j],f[j-cost[i]]+get[i]);
        printf("%d\n",f[V]);
    }
    return 0;
}

分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics