`
java-mans
  • 浏览: 11420379 次
文章分类
社区版块
存档分类
最新评论

HDU 2592 Conuting sheep

 
阅读更多
Problem Description
A while ago I had trouble sleeping. I used to lie awake, staring at the ceiling, for hours and hours. Then one day my grandmother suggested I tried counting sheep after I'd gone to bed. As always when my grandmother suggests things, I decided to try it out. The only problem was, there were no sheep around to be counted when I went to bed.


Creative as I am, that wasn't going to stop me. I sat down and wrote a computer program that made a grid of characters, where # represents a sheep, while . is grass (or whatever you like, just not sheep). To make the counting a little more interesting, I also decided I wanted to count flocks of sheep instead of single sheep. Two sheep are in the same flock if they share a common side (up, down, right or left). Also, if sheep A is in the same flock as sheep B, and sheep B is in the same flock as sheep C, then sheeps A and C are in the same flock.


Now, I've got a new problem. Though counting these sheep actually helps me fall asleep, I find that it is extremely boring. To solve this, I've decided I need another computer program that does the counting for me. Then I'll be able to just start both these programs before I go to bed, and I'll sleep tight until the morning without any disturbances. I need you to write this program for me.

Input
The first line of input contains a single number T, the number of test cases to follow.

Each test case begins with a line containing two numbers, H and W, the height and width of the sheep grid. Then follows H lines, each containing W characters (either # or .), describing that part of the grid.

Output
For each test case, output a line containing a single number, the amount of sheep flock son that grid according to the rules stated in the problem description.

Notes and Constraints
0 < T <= 100
0 < H,W <= 100

Sample Input
2 4 4 #.#. .#.# #.## .#.# 3 5 ###.# ..#.. #.###

Sample Output
6 3
数羊群的群数,“#”为羊,我们只要用BFS遍历把每一群标记即可
LANGUAGE:C
CODE
#include<stdio.h>
#define max 101
typedef struct
{
    int x,y;
}node;
const int dir[4][2]={{0,1},{1,0},{0,-1},{-1,0}};
char map[max][max];
int n,m,fx,fy;
void bfs()
{
    node queue[max*max],cur,temp;
    int rear=0,front=0,i,j;
    cur.x=fx,cur.y=fy;
    map[fx][fy]='.';
    queue[rear++]=cur;
    while(front<rear)
    {
        cur=queue[front++];
        for(i=0;i<4;i++)
        {
            temp.x=cur.x+dir[i][0],temp.y=cur.y+dir[i][1];
            if(temp.x>0&&temp.x<=n&&temp.y>0&&temp.y<=m&&map[temp.x][temp.y]=='#')
            {
                map[temp.x][temp.y]='.';
                queue[rear++]=temp;
            }
        }
    }

}
int main()
{
    int i,j,k,t,count;
    scanf("%d",&t); getchar();
    for(i=0;i<t;i++)
    {
        scanf("%d%d",&n,&m);getchar();
        for(j=1;j<=n;j++)
        {
            for(k=1;k<=m;k++)
            {
                scanf("%c",&map[j][k]);
            }
            getchar();
        }
        count=0;
        for(j=1;j<=n;j++)
        {
            for(k=1;k<=m;k++)
            {
                if(map[j][k]=='#')
                {
                    fx=j,fy=k;
                    bfs();
                    count++;
                }
            }
        }
        printf("%d\n",count);
    }
    return 0;
}


分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics