`
java-mans
  • 浏览: 11412705 次
文章分类
社区版块
存档分类
最新评论

HDOJ 2147 kiki’s game

 
阅读更多
Problem Description
Recently kiki has nothing to do. While she is bored, an idea appears in his mind, she just playes the checkerboard game.The size of the chesserboard is n*m.First of all, a coin is placed in the top right corner(1,m). Each time one people can move the coin into the left, the underneath or the left-underneath blank space.The person who can't make a move will lose the game. kiki plays it with ZZ.The game always starts with kiki. If both play perfectly, who will win the game?

Input
Input contains multiple test cases. Each line contains two integer n, m (0<n,m<=2000). The input is terminated when n=0 and m=0.


Output
If kiki wins the game printf "Wonderful!", else "What a pity!".

Sample Input
5 3 5 4 6 6 0 0

Sample Output
What a pity! Wonderful! Wonderful!

题意:

在一个m*n的棋盘内,从(1,m)点出发,每次可以进行的移动是:左移一,下移一,左下移一。然后kiki每次先走,判断kiki时候会赢(对方无路可走的时候)

LANGUAGE:C

CODE;

#include<stdio.h>
int main ()
{
    int n,m;
    while (scanf("%d%d",&n,&m), n||m )
    {
        if(n%2&&m%2)puts("What a pity!");
        else printf("Wonderful!");
    }
    return 0;
}




分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics